• entries
    6
  • comments
    322
  • views
    106,535

Changes in the Final Release

Uthil

5,426 views

Fixes / Additions :

  • Many fixes around creature / NPC models,
  • Removed some older additions in BETA / Alpha,
  • Added new models for Legendary/Epic weapons
  • Some dbc entries cleaning
  • Added some new creature sounds

Returned to default state : Thrall model, Elemental models, Drake models,

Bat models went back to cata update, Stormwind fountain and general all fountains, Lich models

Under WiP :

  • Working the armor /weapons Patch [going to be released a few days after main mod]

 

BETA Fixes & Additions album:

http://imgur.com/a/VcBog

  • Like 5


27 Comments


Recommended Comments



The game will look (and feel) more like Retail once I install all the file from your mediafire? Last I played was several months ago, when you last released an update, you reckon this update will provide noticeable improvement?

Thanks for your hard work and community contribution!

Share this comment


Link to comment
2 hours ago, Webmaster said:

The game will look (and feel) more like Retail once I install all the file from your mediafire? Last I played was several months ago, when you last released an update, you reckon this update will provide noticeable improvement?

Thanks for your hard work and community contribution!

As i describe, the point was to change the looks but stay near the classic feeling. Just get all nice parts and unrar them to get the patch file. Many thing was done in BETA, like was done 80% of the mod, i added since then some extra creatures, made fixes etc. You will notice those additions. Check on the imgur album on the entries to see what i add/fixed. Thanks for like the mod.

Share this comment


Link to comment

Not sure if its just on my end but the Stormpike battle charger (the ram) has some texture issues, and the frost saber mount and pet like the one from winterspring has texture isssues. otherwise everything is lookin great man! thankyou!

Share this comment


Link to comment
2 hours ago, Swrrp said:

Not sure if its just on my end but the Stormpike battle charger (the ram) has some texture issues, and the frost saber mount and pet like the one from winterspring has texture isssues. otherwise everything is lookin great man! thankyou!

I reply to your message, but this apply for all, delete the old patch file, no need any more but i've been asked too many times. Delete cache (WDB) folder. In case you are using Balsh character models, rename it to patch-4 or 5. Gonna recheck those mounts late tonight but im sure no problems for the mounts.

UPDATE

@Swrrp I checked also those mounts with Balsh mods, no problem at all, something else is getting wrong for you. Check the pictures bellow in the spoiler.

 

Spoiler

WoWScrnShot_110716_123925.thumb.jpg.6069WoWScrnShot_110716_123941.thumb.jpg.b155

 

 

 

Share this comment


Link to comment

Thank you so much for all your work! I have a problem, I extracted the patch and put it in the data folder and did everything correctly but the character models are all still Vanilla models (new class icons, pets and mounts are WOD and working fine).

Also some things I noticed:

1) The size of undead in the character select screen are bigger than they should be (are they supposed to be bigger than Tauren?) and go out of the screen a little and
2) The lighting/beams of light of the undead character screen background seems strange though I'm not sure if it's supposed to be like this I apologize if it is, also below is a Tauren in character select for comparison:wow2.thumb.jpg.6709ffdd796318e474520f343wow1.thumb.jpg.4fe96a75a5fb79b44ef163794

 

Share this comment


Link to comment
53 minutes ago, qujen said:

Thank you so much for all your work! I have a problem, I extracted the patch and put it in the data folder and did everything correctly but the character models are all still Vanilla models (new class icons, pets and mounts are WOD and working fine).

Also some things I noticed:

1) The size of undead in the character select screen are bigger than they should be (are they supposed to be bigger than Tauren?) and go out of the screen a little and
2) The lighting/beams of light of the undead character screen background seems strange though I'm not sure if it's supposed to be like this I apologize if it is, also below is a Tauren in character select for comparison:

 

Spoiler

wow2.thumb.jpg.6709ffdd796318e474520f343wow1.thumb.jpg.4fe96a75a5fb79b44ef163794

 

 

You did correct about adding the patch in the correct folder, tho i dont have changed the character models, this is done by Balsh. Im also saying what changes/reverses occurred to the models ;) . I provide links on the project about the models. Thanks tho for providing the info as an error.

1) Those lightbeams can be fixed if you enables Vertex animation Shaders under video options. Another lad had similar issue and he reported that he fix it by doing that. Now about the size of the undead screen unfortunately i tried many times to fix but didnt succed. I guess no big deal so i left it as it is.

2)Now the Sun beam in many character screens is normal, it does exists on new game version so no worries.

 

Share this comment


Link to comment

awesome work!  I think this is a must have to play vanilla nowadays - super awesome!  I cam across an issue so far - let me report it.  I am using Balsh's mod also.  There is an issue with the kobold npc's in the beginning human area - they seem to have dark antlers?  I haven't played after WoTLK/Cata so I dunno if they are supposed to have antlers or not...

WoWScrnShot_110716_111921.tga

Share this comment


Link to comment
20 minutes ago, dezzlocks said:

awesome work!  I think this is a must have to play vanilla nowadays - super awesome!  I cam across an issue so far - let me report it.  I am using Balsh's mod also.  There is an issue with the kobold npc's in the beginning human area - they seem to have dark antlers?  I haven't played after WoTLK/Cata so I dunno if they are supposed to have antlers or not...

WoWScrnShot_110716_111921.tga

Yes they have antlers cause they are replaced from new legion model. It might been changed after release but also more things changed with the coming of legion as for models. So i kept that pre-legion release. Cheers!

Share this comment


Link to comment

Uhm it seems that is your issue. Yes couldn't access your screenshot. Ok im gonna check it laters since im at work now. Did you left my patch as it is or did you rename it ? Leave my patch file as it is in name, rename Balsh patch-5 or 6 as it is.

Share this comment


Link to comment

I must be special because i can't find a download link for these files any where. O_O

 

*found it

Share this comment


Link to comment
11 minutes ago, dezzlocks said:

I have yours as patch-3.mpq and Balsh as patch-5.mpq.  I deleted beta patch-4.mpq

I checked and this is working fine :

WoWScrnShot_110916_011607.thumb.jpg.8905

Is this still a problem for you ? Also raise your graphics under video options to max. I've seen that lowering your graphics might cause those black textures and beams.

Share this comment


Link to comment

I just tried another computer - I deleted WDB/*  - I am still seeing the issue.  Here are my video settings

 

edit: I also tried with all addons disabled, still same issue

 

WoWScrnShot_110816_192153.jpg

Share this comment


Link to comment

Ok can you try to use my 4Gb patched .exe file and tell if you still got this error ? All Kobolds are totally fine, i went on every spot i could remember in Elwynn and other areas. I would like also to suggest also to delete my patch and re-download it just in case. The case you facing right now is that doesn't load the textures which are working totally fine. Try the .exe first.

Share this comment


Link to comment

 

5 hours ago, dezzlocks said:

I tried both WoW.exe's - same issue.  I'm downloading  the client from kronos, will report back.

Cool i really would love to know if that was client side problem or something was interfering and you had that issue.Thanks for providing updates for your post. 

Share this comment


Link to comment

ok I found the issue - it's Balsh's mpq

I deleted patch-5.mpq and everything worked fine, I guess there is some sort of conflict somewhere I suppose

 

 

WoWScrnShot_111016_123620.jpg

Share this comment


Link to comment
36 minutes ago, dezzlocks said:

ok I found the issue - it's Balsh's mpq

I deleted patch-5.mpq and everything worked fine, I guess there is some sort of conflict somewhere I suppose

WoWScrnShot_111016_123620.jpg

Im glad that it worked. Ok then check since balsh has updated his patch into a newer version with fixes from leviaathan. Also which patch you had cause he has 2 version, one that has druid forms and is stand alone and one made to be compatible with my patch. In case you want character models get the correct version. Thanks for providing info about your problem.

Share this comment


Link to comment

looking at Balsh's site again, seems patch-5.mpq is the druid forms one and patch-6.mpq is the non-druids form version, so I appear to have downloaded the wrong version initially

 

 

  • Like 1

Share this comment


Link to comment

It was also the wrong balsh patch for me too. everything is fixed. thank you dezzlocks and balsh for the great info!

  • Like 1

Share this comment


Link to comment
1 hour ago, janos said:

how can i download this mod? i cant find it. :(

Press on the mod it self not the entries. Where it say Reveal Hidden Content, guys please read carefully a topic,  much easier cant be. ;)

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now