Improved Water for 3.3.5a [WORKING] 1.1.1

   (0 reviews)

3 Screenshots

About This File

This patch includes the improved procedural water that was tested in the 3.3.5a client.

- This patch finally fixes the 'bright white' water glitch that would occur with other modders' water patches.
- The colours for all water types, including all WMO water, Hyjal water and Coilfang indoor water should now be fixed.
- The water has the intended animated 'wave' effects, ripple textures and reflection maps.
- This patch also includes improved textures for Slime and Lava!

Please note that whilst this water is improved, it does not look like Cataclysm water. This was made possible due to the fact that Blizzard were experimenting with improved water in 3.3.5a. In outdoor zones, it generally looks better than the old water.

 

 

 


What's New in Version 1.1.1   See changelog

Released

WMO WATER FIXED FINALLY
 

  • Like 9
  • Confused 1



User Feedback

Recommended Comments

Hey, this has been a long time coming! Out of curiosity how did you manage to make the fix? Was it a change of .blp or through some crafty dbc editing?

Share this comment


Link to comment
Share on other sites

Mostly a problem with the LiquidType.dbc and the textures mate. Some of the textures I had initially weren't ported to 3.3.5a structure properly and made the sea appear green. I had to merge the water folder with Cataclysm textures and figure it out from there
 

Share this comment


Link to comment
Share on other sites

Water is still bugged in Dalaran and Stormwind, will this ever get a fix for those areas?

Share this comment


Link to comment
Share on other sites
On 5/1/2020 at 11:12 AM, 3idolon said:

Water is still bugged in Dalaran and Stormwind, will this ever get a fix for those areas?

Working on it my friend - expecting a release soon with version 1.0.0

Share this comment


Link to comment
Share on other sites

Does not work for me, water still white and bugged

Screenshot_1.png

I have some patches for legion character models and creature models

 

Screenshot_2.png

Share this comment


Link to comment
Share on other sites

I am getting the green water texture in 1.0.1 in stormwind city canals. 

  • Thanks 1

Share this comment


Link to comment
Share on other sites

I can confirm, the water is green in stormwind city canals, and dalaran. Also this house in Teldrassil. I was unable to get the white water issue in Darnassus.

 

image.thumb.png.ac39687ec72191ef7c59d893f3c72809.png

Share this comment


Link to comment
Share on other sites

Any chance of changing the lava and slime to look like the ones from  WOD? Stygian's WOD Lava/Slime  patch looks better than the included lava and slime here, but the water here is beautiful. 

Share this comment


Link to comment
Share on other sites

Hi, I'd like to know if this white bug can be fixed somehow, thing is I have also patch4, should I delete it? I've got the stygiancore repack installed, and I see that this file is Patch6, is there something I need to do? Someone knows something 'bout it?
 

Wow 2020-10-27 13-11-39.png

Share this comment


Link to comment
Share on other sites
On 10/27/2020 at 12:13 PM, Ceramic Pots said:

Hi, I'd like to know if this white bug can be fixed somehow, thing is I have also patch4, should I delete it? I've got the stygiancore repack installed, and I see that this file is Patch6, is there something I need to do? Someone knows something 'bout it?
 

Hey dude. Try the new patch. If it doesn't work, let me know. Are you on Windows or another OS?

Share this comment


Link to comment
Share on other sites

Well done work mate! But there is only one thing which I dont like.

Could you change the slime in front of the Ruins of Lordaeron?  It looks weird like a animation is missing or something. :)

WoWScrnShot_110520_044957.thumb.jpg.b63dd125a699271ee653839456f8d131.jpg

WoWScrnShot_110520_045915.thumb.jpg.1e835d5acae870d9a8cf90874a265ef7.jpg

Share this comment


Link to comment
Share on other sites

Odd. The water shows the correct texture on my PC, but that lighting error is still prevalent

Share this comment


Link to comment
Share on other sites

So far its working good for me on latest version... however that bright light in the water opposite of the direction the light is coming from occurs here and there.

Share this comment


Link to comment
Share on other sites
20 hours ago, crum said:

So far its working good for me on latest version... however that bright light in the water opposite of the direction the light is coming from occurs here and there.

Yeah dude. That is a feature - it is supposed to be a specular lighting effect

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now