Uthil

release
[WiP] WoD Retro porting to Classic WoW 1.12

On 16/10/2016 at 9:33 AM, Uthil said:

As requested Dagun now is an original old god ! :) 

Spoiler

WoWScrnShot_101616_102718.thumb.jpg.1af2

**** UPDATE

Seems that the specific model affects some sea giant model, even if i change only Dagun. Under investigation!

A thousand blessings upon you, sir. <3

Share this post


Link to post
Share on other sites

Final updates and tests done, haven't found anything wrong till now. I have gather up the weapon fixes/additions that will be on the main mod, rest will be later released with the armor patch. My journey ended and was fun and had bad moments and good ones. Want to thanks in advance all who participated from less to big help, without you motivate me plus all VANILLA FANS i wouldn't had this mod released. Started to work the D/L links. See ya all soon! biggrin.giflaugh.gif

Thunderfury - Legion model replacement !

z0V151I.jpg

9wT379I.jpg


Zin'rohk - Cata model replacement !

MUp53Jv.jpg

LkwCp27.jpg

Sulfuras - Cata model replacement !

HZFMSM7.jpg

sDTjFsW.jpg

 

Those weapons will be released with the armor patch, since it required different approach and couldnt make them work with the main mod.

Soul Harvester - Legion model replacement !

ZzjfFAY.jpg

q8x3WrP.jpg


Lok'Delar, Stave of the Ancient Keeper - Legion model replacement !

b1TGiMy.jpg


Rhok'Delar - Longbow of the Ancient Keepers - Legion model replacement !

uOcc9ct.jpg

Also the latest updates before those final on the album, can be seen here :

http://imgur.com/a/VcBog

Uthil out!

 

  • Like 1

Share this post


Link to post
Share on other sites

Very nice! By the way, I noticed some fixes (no more black textures in some places) but I don't know if you did it or was it because I deleted WDB again. Anyway, three new things I noticed:

Wings on bug trio have no texture, totally black (I can try new drivers, new WDB, re-entering instance, but if others have this problem, it might not be me).

Spoiler

_bug_trio.jpg.ee9bad9d82f001f2f2a597a45f

 

Spotted tiger mount has a black tail:

Spoiler

_mount2.jpg.55d022e078d447b7be465c4f6d07

 

White tiger mount has visible lines on hind legs:

Spoiler

_mount1.jpg.ecbb5f30f8248e515d94d6f57340

I also wonder if you could release the earth elementals separately, because they worked fine. Maybe there are also other elemental models that can be used instead (for fire, water, air), and not the ones you tried? Those can also be released as a separate patch. And lastly, you fixed the hyppogryph nest textures (for Night Elf flight masters), but isn't there also a new model available?

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, drood182 said:

Very nice! By the way, I noticed some fixes (no more black textures in some places) but I don't know if you did it or was it because I deleted WDB again. Anyway, three new things I noticed:

Wings on bug trio have no texture, totally black (I can try new drivers, new WDB, re-entering instance, but if others have this problem, it might not be me).

  Hide contents

_bug_trio.jpg.ee9bad9d82f001f2f2a597a45f

 

Spotted tiger mount has a too dark tail:

  Reveal hidden contents

_mount2.jpg.55d022e078d447b7be465c4f6d07

 

White tiger mount has visible lines on hind legs:

  Reveal hidden contents

_mount1.jpg.ecbb5f30f8248e515d94d6f57340

I also wonder if you could release the earth elementals separately, because they worked fine. Maybe there are also other elemental models that can be used instead (for fire, water, air), and not the ones you tried? Those can also be released as a separate patch. And lastly, you fixed the hyppogryph nest textures (for Night Elf flight masters), but isn't there also a new model available?

Thanks for submitting those. Going to check 1 by 1 laters. As for elementals i tested all elemental models after WotLK (since didnt like those Revenant elementals much) and all had same particles issue. So i thought its best to replace them on their old state. I can make an attempt for those but really later, now i need a small break from it since im also spend some time to finish the armor models.

Share this post


Link to post
Share on other sites

Hey guys!

I have a problem at the installation. After I downloaded all the patches, every patch that I want to extract is called "patch-3.mpq" so Windows wants to replace the one I extracted before... I think I'm doing something wrong ^^

Thanks 

Rob

  

Share this post


Link to post
Share on other sites
1 hour ago, itsRob said:

Hey guys!

I have a problem at the installation. After I downloaded all the patches, every patch that I want to extract is called "patch-3.mpq" so Windows wants to replace the one I extracted before... I think I'm doing something wrong ^^

Thanks 

Rob

  

You just right click on the 1st rar file and you choose to unrar it where you want to. This it will give you 1 single file that you have to move to it under Data folder.

Share this post


Link to post
Share on other sites
7 hours ago, drood182 said:

Very nice! By the way, I noticed some fixes (no more black textures in some places) but I don't know if you did it or was it because I deleted WDB again. Anyway, three new things I noticed:

Wings on bug trio have no texture, totally black (I can try new drivers, new WDB, re-entering instance, but if others have this problem, it might not be me).

  Hide contents

_bug_trio.jpg.ee9bad9d82f001f2f2a597a45f

 

Spotted tiger mount has a black tail:

  Reveal hidden contents

_mount2.jpg.55d022e078d447b7be465c4f6d07

 

White tiger mount has visible lines on hind legs:

  Reveal hidden contents

_mount1.jpg.ecbb5f30f8248e515d94d6f57340

I also wonder if you could release the earth elementals separately, because they worked fine. Maybe there are also other elemental models that can be used instead (for fire, water, air), and not the ones you tried? Those can also be released as a separate patch. And lastly, you fixed the hyppogryph nest textures (for Night Elf flight masters), but isn't there also a new model available?

Ok first bug that i missed in those AQ Bosses. Thanks gonna fix it soon. Now about tigers that must be a design flaw since those are made by finsternis. His work is really good but not sure if that can be corrected or done whole skin from the begging.

Share this post


Link to post
Share on other sites

First post here, first off I want to say THANK YOU UTHIL for this amazing mod! I'm very excited to use it while playing on the new Nostralius server in another month. 

But anyway I had a question, were the WoD character models taken out in your newest update/final release? Because the human and troll look normal vanilla. Or is the model changes coming with your armor/weapon patch? Sorry, I just can't seem to find anyone mentioning that recently. 

Thanks!

Share this post


Link to post
Share on other sites
27 minutes ago, Gnreign said:

First post here, first off I want to say THANK YOU UTHIL for this amazing mod! I'm very excited to use it while playing on the new Nostralius server in another month. 

But anyway I had a question, were the WoD character models taken out in your newest update/final release? Because the human and troll look normal vanilla. Or is the model changes coming with your armor/weapon patch? Sorry, I just can't seem to find anyone mentioning that recently. 

Thanks!

On the Project section of changes i have a link from balsh. He did the character models. I had them too, not all done and was under alpha state since i was working this mod. Was going to mess with them after i was done with the main mod but balsh manage to do it he helped me focus more on main project.

Share this post


Link to post
Share on other sites

Found a few more things:

ZG raptor (not the mount, the boss; the mount is OK)

Spoiler

err01.jpg.5b77fe7d67d4e8e6b2321d08578b4c

 

Frostsaber tigers (No idea if mount is OK, haven't see one in a while):

Spoiler

err02.jpg.e8ebbb4fd66d0e24b22576a3ded9f3

 

Yellow scorpids (grey face, also it has parts mixed with the red scorpid texture, like the tail):

Spoiler

err03.jpg.70d4d2ab0191044c7c021f25972ee6

 

This moonkin model:

Spoiler

err04.jpg.070b8d7792bd091f22d23e4eb2397a

 

Did you also replace chimaeras with the old model? I think the new model is much better, regardless of casting animation.

Share this post


Link to post
Share on other sites

Thanks for the reports. I can confirm those missing the specific textures. Gonna check them. Also i fixed the AQ bosses and was going go release the update version. Got me on time. Thanks mate.

Yes also i reverse the chimeras back to their old models since you couldn't see when they was casting. Was too overloaded from work to start looking why this animation doesn't play and see if i could fix it.

I also finalized the T1 armors, they need some final checks and gonna move to T3. Added Quel'Sellar, Mantokir's Sting, Hoodoo Bow.

Paladin

k3vGOmq.jpg

Warrior

pk0kwPN.jpg

Shaman

TwOy4RJ.jpg

Warlock

he3Hmtq.jpg

Rogue

RUSFsJ9.jpg

Quel'Serrar [WotLK model replacement]

c6aFPgy.jpg

Mandokir's Sting [Cata model replacement]

BTWcSme.jpg

Hoodoo Hunting Bow [Cata model replacement]

UK7Geja.jpg

Whole album preview here

 

 

  • Like 1

Share this post


Link to post
Share on other sites

So hey I was just playing and noticed some epic mounts that are messed up pretty badly. I don't know if you're aware or if anyone else is having this issue, maybe it's just something on my end? Do you know of anything I could do to fix this if it is on my end?

Epic undead mounts, epic orc mounts, epic troll mounts, epic dwarf mounts, epic human mounts, and the non-epic tauren mount.

 

 

Spoiler

3.thumb.PNG.eb3ee383898bb429d7fafbbb623f4.thumb.PNG.44d4ce046859be0293a3ede2b0515.thumb.PNG.12f723fd3582ba353040cd3403e06.thumb.PNG.86061e58e718f1c8a2e459bdaa467.thumb.PNG.086ff70ea25a4801ba62a7e88df21.thumb.PNG.78f450930780b80b9ac715c9826b2.thumb.PNG.5977e3f93f80825f1fcc453d5552

 

Share this post


Link to post
Share on other sites
8 hours ago, Gnreign said:

So hey I was just playing and noticed some epic mounts that are messed up pretty badly. I don't know if you're aware or if anyone else is having this issue, maybe it's just something on my end? Do you know of anything I could do to fix this if it is on my end?

Epic undead mounts, epic orc mounts, epic troll mounts, epic dwarf mounts, epic human mounts, and the non-epic tauren mount.

 

 

  Reveal hidden contents

3.thumb.PNG.eb3ee383898bb429d7fafbbb623f4.thumb.PNG.44d4ce046859be0293a3ede2b0515.thumb.PNG.12f723fd3582ba353040cd3403e06.thumb.PNG.86061e58e718f1c8a2e459bdaa467.thumb.PNG.086ff70ea25a4801ba62a7e88df21.thumb.PNG.78f450930780b80b9ac715c9826b2.thumb.PNG.5977e3f93f80825f1fcc453d5552

 

Ill check them out, tho which patch of balsh for character models you are using ? He has 2, one for stand alone use and one made for my patch. 

Share this post


Link to post
Share on other sites
3 hours ago, Uthil said:

Ill check them out, tho which patch of balsh for character models you are using ? He has 2, one for stand alone use and one made for my patch. 

That was it! lol I'm a fool, thanks for helping me! The only thing I've been able to find after fixing which version of Balsh's patch I was using is this: the hooves on the green epic undead mount. other than that literally everything else seems perfect! Thank you! 

Spoiler

8.thumb.PNG.c94954236a0ba208dddf7879b3e6

 

  • Like 2

Share this post


Link to post
Share on other sites
On 15/11/2016 at 7:57 PM, Gnreign said:

That was it! lol I'm a fool, thanks for helping me! The only thing I've been able to find after fixing which version of Balsh's patch I was using is this: the hooves on the green epic undead mount. other than that literally everything else seems perfect! Thank you! 

  Reveal hidden contents

8.thumb.PNG.c94954236a0ba208dddf7879b3e6

 

I've checked it since i couldn't remember after so many changes that i've made. xD So the hooves of the horse have correct textures, no problem at all, that is the color of their hooves.

Share this post


Link to post
Share on other sites

Have you figured a way to use separate model for Dagun and Deepstrider Giants? It's really a shame if they can't be separated. I think you also switched bats to old models. I really prefer the newer ones.

Share this post


Link to post
Share on other sites
7 hours ago, drood182 said:

Have you figured a way to use separate model for Dagun and Deepstrider Giants? It's really a shame if they can't be separated. I think you also switched bats to old models. I really prefer the newer ones.

No since they use the same entry i cant touch it unfortunately. I'll re-recheck it laters since im working the fixes and some alpha tests on armors.

Share this post


Link to post
Share on other sites

Hello Uthil,

Here is a little overview for you.

1) Some models mounts (I noticed only rapotors) is not replaced

2) fire totem not displayed or it is just an older version

3) also, some bug with shaman form when we starting combat


Everything else look like great.

Thank you for your project!

 

WoWScrnShot_111916_022530.tga

WoWScrnShot_111916_022627.tga

WoWScrnShot_111916_022726.tga

Share this post


Link to post
Share on other sites
2 hours ago, Thron said:

Hello Uthil,

Here is a little overview for you.

1) Some models mounts (I noticed only rapotors) is not replaced

2) fire totem not displayed or it is just an older version

3) also, some bug with shaman form when we starting combat

Everything else look like great.

Thank you for your project!

WoWScrnShot_111916_022530.tga

WoWScrnShot_111916_022627.tga

WoWScrnShot_111916_022726.tga

Hey thanks that you like the mod and the feedback, so :

1. for those 60% mounts i didnt change them, was focused mostly on 100%, just happen to replace wolfs and tigers for the other races

2. Yes i didnt replace the fire totem cause this model is used also elsewhere so the new model wasnt fiting at all.

3. Ill investigate since the shaman wolf mode change existed since Beta and none reported me a bug with it.

Cheers Uthil

Share this post


Link to post
Share on other sites

I can't for the life of me find where to download this, all I see in this thread are Screenshots, no links.

Share this post


Link to post
Share on other sites
13 minutes ago, Allastair said:

I can't for the life of me find where to download this, all I see in this thread are Screenshots, no links.

You will find it here.

 

Share this post


Link to post
Share on other sites

Ok fixes are done after the reports, thanks all that report those errors that i missed during the final tests. Also i update Ouro to the newer cata model.
 

Raptor Boss on AQ fixed

wHPosWW.jpg

Berserk Owlbeasts fixed

VuT5ugC.jpg

Frostsaber Pride Watcher fixed

AQkIp3o.jpg

Bug Trio wings fixed

6ejwBZ5.jpg

Ouro Cata model replacement

UDOLwGA.jpg

Aalso have started to update T3 Sets on the armor Patch. Actually T19 to T3.

Mage T19->T3

j66pZhH.jpg

Druid T19->T3

TZWaCD4.jpg

Rest T3 is under WiP, T1 is done.

Uthil out!

  • Like 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now