grimclaw87

Need help with server compile

Hello i need some help with trinity source compile 

I followed instructions and download programs from :

https://trinitycore.atlassian.net/wiki/spaces/tc/pages/10977296/Windows+Requirements

I downloaded a trinity source from :

https://github.com/Quadral/335source

So after i open C Make program and setting source and build paths, i press configure,choose the right Visual studio version,64 bit

I get this error  and can't compile source :

error.jpg.62e8b1acebdea3b88aa6844aeed771dd.jpg

 

The console of C Make with the errors  says :

 

Selecting Windows SDK version 10.0.17763.0 to target Windows 10.0.17134.
CMake Deprecation Warning at CMakeLists.txt:16 (cmake_policy):
  The OLD behavior for policy CMP0005 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.


CMake Deprecation Warning at CMakeLists.txt:18 (cmake_policy):
  The OLD behavior for policy CMP0043 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.


Detected 64-bit platform
MSVC: 64-bit platform, enforced -D_WIN64 parameter
MSVC: Enabled increased number of sections in object files
MSVC: Overloaded standard names
MSVC: Disabled NON-SECURE warnings
MSVC: Disabled POSIX warnings
MSVC: Disabled generic compiletime warnings
Found OpenSSL library: optimized;SSL_EAY_RELEASE-NOTFOUND;LIB_EAY_RELEASE-NOTFOUND;debug;SSL_EAY_DEBUG-NOTFOUND;LIB_EAY_DEBUG-NOTFOUND
Found OpenSSL headers: C:/Program Files/OpenSSL-Win64/include
CMake Warning (dev) at cmake/macros/ConfigureBoost.cmake:32 (find_package):
  Policy CMP0074 is not set: find_package uses <PackageName>_ROOT variables.
  Run "cmake --help-policy CMP0074" for policy details.  Use the cmake_policy
  command to set the policy and suppress this warning.

  Environment variable Boost_ROOT is set to:

    C:/local/boost_1_66_0

  For compatibility, CMake is ignoring the variable.
Call Stack (most recent call first):
  CMakeLists.txt:62 (include)
This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Error at cmake/macros/FindBoost.cmake:1184 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.66.0

  Boost include path: C:/local/boost_1_66_0

  Could not find the following static Boost libraries:

          boost_system
          boost_filesystem
          boost_thread
          boost_program_options
          boost_iostreams

  No Boost libraries were found.  You may need to set BOOST_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
  Boost.
Call Stack (most recent call first):
  cmake/macros/ConfigureBoost.cmake:32 (find_package)
  CMakeLists.txt:62 (include)


Performing Test boost_filesystem_copy_links_without_NO_SCOPED_ENUM
CMake Warning (dev) at C:/Users/User/Downloads/cmake-3.14.1-win32-x86/share/cmake-3.14/Modules/CheckCXXSourceCompiles.cmake:110 (try_compile):
  Policy CMP0066 is not set: Honor per-config flags in try_compile()
  source-file signature.  Run "cmake --help-policy CMP0066" for policy
  details.  Use the cmake_policy command to set the policy and suppress this
  warning.

  For compatibility with older versions of CMake, try_compile is not honoring
  caller config-specific compiler flags (e.g.  CMAKE_C_FLAGS_DEBUG) in the
  test project.
Call Stack (most recent call first):
  cmake/macros/ConfigureBoost.cmake:45 (check_cxx_source_compiles)
  CMakeLists.txt:62 (include)
This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) at C:/Users/User/Downloads/cmake-3.14.1-win32-x86/share/cmake-3.14/Modules/CheckCXXSourceCompiles.cmake:110 (try_compile):
  Policy CMP0056 is not set: Honor link flags in try_compile() source-file
  signature.  Run "cmake --help-policy CMP0056" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  For compatibility with older versions of CMake, try_compile is not honoring
  caller link flags (e.g.  CMAKE_EXE_LINKER_FLAGS) in the test project.
Call Stack (most recent call first):
  cmake/macros/ConfigureBoost.cmake:45 (check_cxx_source_compiles)
  CMakeLists.txt:62 (include)
This warning is for project developers.  Use -Wno-dev to suppress it.

Performing Test boost_filesystem_copy_links_without_NO_SCOPED_ENUM - Failed
Found git binary : C:/Program Files/Git/cmd/git.exe

    Could not find a proper repository signature (hash) - you may need to pull tags with git fetch -t
    Continuing anyway - note that the versionstring will be set to "unknown 1970-01-01 00:00:00 (Archived)"

* TrinityCore revision   : unknown 1970-01-01 00:00:00 +0000 (Archived branch)

* Install core to        : C:/Program Files (x86)/TrinityCore

* Build world/auth       : Yes (default)
* Build with scripts     : Yes (default)
* Build Eluna LuaEngine   : Yes (default)
* Build map/vmap tools   : No  (default)
* Build core w/PCH       : Yes (default)
* Build scripts w/PCH    : Yes (default)
* Show compile-warnings  : No  (default)
* Use coreside debug     : No  (default)
* Show source tree       : Yes - hierarchical
* Use GIT revision hash  : Yes

   Entering             C:/WowServer/TrinityCore/dep
   Entering             C:/WowServer/TrinityCore/dep/zlib
   Returning to         C:/WowServer/TrinityCore/dep
   Entering             C:/WowServer/TrinityCore/dep/g3dlite
   Returning to         C:/WowServer/TrinityCore/dep
   Entering             C:/WowServer/TrinityCore/dep/recastnavigation
   Entering             C:/WowServer/TrinityCore/dep/recastnavigation/Detour
   Returning to         C:/WowServer/TrinityCore/dep/recastnavigation
   Entering             C:/WowServer/TrinityCore/dep/recastnavigation/Recast
   Returning to         C:/WowServer/TrinityCore/dep/recastnavigation
   Returning to         C:/WowServer/TrinityCore/dep
   Entering             C:/WowServer/TrinityCore/dep/cppformat
   Returning to         C:/WowServer/TrinityCore/dep
   Entering             C:/WowServer/TrinityCore/dep/gsoap
   Returning to         C:/WowServer/TrinityCore/dep
   Entering             C:/WowServer/TrinityCore/dep/lualib
   Returning to         C:/WowServer/TrinityCore/dep
   Returning to         C:/WowServer/TrinityCore
   Entering             C:/WowServer/TrinityCore/src
   Entering             C:/WowServer/TrinityCore/src/genrev
   Returning to         C:/WowServer/TrinityCore/src
   Entering             C:/WowServer/TrinityCore/src/common
   Returning to         C:/WowServer/TrinityCore/src
   Entering             C:/WowServer/TrinityCore/src/server
Found MySQL library: C:/Program Files/MySQL/MySQL Server 5.7/lib/libmysql.lib
Found MySQL headers: C:/Program Files/MySQL/MySQL Server 5.7/include
Found MySQL executable: C:/Program Files/MySQL/MySQL Server 5.7/bin/mysql.exe
   Entering             C:/WowServer/TrinityCore/src/server/database
   Returning to         C:/WowServer/TrinityCore/src/server
   Entering             C:/WowServer/TrinityCore/src/server/shared
   Returning to         C:/WowServer/TrinityCore/src/server
   Entering             C:/WowServer/TrinityCore/src/server/game
   Returning to         C:/WowServer/TrinityCore/src/server
   Entering             C:/WowServer/TrinityCore/src/server/authserver
   Returning to         C:/WowServer/TrinityCore/src/server
   Entering             C:/WowServer/TrinityCore/src/server/scripts
SCRIPT PREPARATIONS
  -> Prepared: Spells
  -> Prepared: Commands
  -> Prepared: Custom
  -> Prepared: World
  -> Prepared: Outdoor PVP Zones
  -> Prepared: Eastern Kingdoms
  -> Prepared: Kalimdor
  -> Prepared: Outland
  -> Prepared: Northrend
  -> Prepared: Events
  -> Prepared: Pet
SCRIPT PREPARATION COMPLETE

   Returning to         C:/WowServer/TrinityCore/src/server
   Entering             C:/WowServer/TrinityCore/src/server/worldserver
   Returning to         C:/WowServer/TrinityCore/src/server
   Returning to         C:/WowServer/TrinityCore/src
   Entering             C:/WowServer/TrinityCore/src/LuaEngine
CMake Warning (dev) at src/LuaEngine/CMakeLists.txt:145 (find_package):
  Policy CMP0074 is not set: find_package uses <PackageName>_ROOT variables.
  Run "cmake --help-policy CMP0074" for policy details.  Use the cmake_policy
  command to set the policy and suppress this warning.

  Environment variable Boost_ROOT is set to:

    C:/local/boost_1_66_0

  For compatibility, CMake is ignoring the variable.
This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Error at cmake/macros/FindBoost.cmake:1184 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.66.0

  Boost include path: C:/local/boost_1_66_0

  Could not find the following static Boost libraries:

          boost_system
          boost_filesystem

  No Boost libraries were found.  You may need to set BOOST_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
  Boost.
Call Stack (most recent call first):
  src/LuaEngine/CMakeLists.txt:145 (find_package)


   Returning to         C:/WowServer/TrinityCore/src
   Returning to         C:/WowServer/TrinityCore
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LIB_EAY_DEBUG (ADVANCED)
    linked by target "authserver" in directory C:/WowServer/TrinityCore/src/server/authserver
    linked by target "worldserver" in directory C:/WowServer/TrinityCore/src/server/worldserver
LIB_EAY_RELEASE (ADVANCED)
    linked by target "authserver" in directory C:/WowServer/TrinityCore/src/server/authserver
    linked by target "worldserver" in directory C:/WowServer/TrinityCore/src/server/worldserver
SSL_EAY_DEBUG (ADVANCED)
    linked by target "authserver" in directory C:/WowServer/TrinityCore/src/server/authserver
    linked by target "worldserver" in directory C:/WowServer/TrinityCore/src/server/worldserver
SSL_EAY_RELEASE (ADVANCED)
    linked by target "authserver" in directory C:/WowServer/TrinityCore/src/server/authserver
    linked by target "worldserver" in directory C:/WowServer/TrinityCore/src/server/worldserver

Configuring incomplete, errors occurred!
See also "C:/WowServer/build/CMakeFiles/CMakeOutput.log".
See also "C:/WowServer/build/CMakeFiles/CMakeError.log". 

 

Any idea what's wrong with my settings ?

Did i forgot something to do ?

Share this post


Link to post
Share on other sites

Have you set boost file path in to your system? Cmake cant find it its in that log you posted. Its all on trinity website manual.

Share this post


Link to post
Share on other sites
3 hours ago, Sacrotar said:

Have you set boost file path in to your system? Cmake cant find it its in that log you posted. Its all on trinity website manual.

I have go to my sytem advanced settings and create 2 environments.

BOOST_ROOT and BOOST_LIBRARYDIR with the paths to boost and boost library.

 

I also tryed to add manually the paths in C make list inside my trinity source folder and nothing.

Share this post


Link to post
Share on other sites

Well BOOST_LIBRARYDIR is not sessesary to have set. Make sure you set it in both system path and user path just in case (just root). Its complaining about missing libraries so either your boost is busted and missing files or more likely you made a msitake seting the path to it.... Seting up Cmake for the first time is pain i know i bet once you manage to fix boost it will cry about Open SSL its what hapened to me. Also try switching from 5.7 MySQL to 5.6 just works better with everything. Go over the tutorial on trinity again its quite detailed on its own.

Share this post


Link to post
Share on other sites

Nevermind I gave up :)

I tried install boost 1.59 then boost 1.55

I tried installing my sql server 5.6 then 5.5

I tried changing the source file with official trinity source

I tried changing settings of C make that search for boost

I tried installing another version of visual studio

Nothing worked so far :)

Share this post


Link to post
Share on other sites

use boost_1_66_0 and make sure you add it to windows environment path then run cmake once you get to the configure window make sure you select x64 in the optional platform drop down then press finish, if you done it right then it should work :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now