Kaleesh

[Help} Trying to downport a Cataclysm mount to 3.3.5; cannot find the WotLK animation files to change them

Right, so to go along with my mummy troll skin, I wanted to replace a Swift Raptor with the Skeletal Raptor model. The thing is, I can't find the .anim files for the Swift Riding Raptors to replace them. I know there is a certain amount of data in the DBCs, but not all of it, surely?

While knowing little about downporting, this is the monstrosity I was able to accomplish without the ability to add the right animations, lol:

https://i.gyazo.com/0a13b987fd61f04c3ba8a6ded75d8248.mp4

A little concerned that animations aren't the only issue. I used the Legion-to-WotLK porter in the downloads section of this site, which brought it into a state where it is visible and my character can mount it, at least.  One thing, though-- It did nothing to the .anim files. I assume this is because those files don't need to be converted?

Share this post


Link to post
Share on other sites

Well, okay, but could you expand on that a little? There is still something somewhere that needs to be changed, seeing as the animations are not baked into the m2 as evidenced by my model replacement still animating itself like the original swift raptor while not having access to any skeletal raptor anims,

Share this post


Link to post
Share on other sites

I just explained to you that the Swift Raptor animations are not baked into its M2, after you told me the Swift Raptor does not have any anim files. And now you say that if it is not part of the M2 it must have anim files. Which is it?

Share this post


Link to post
Share on other sites
7 hours ago, Alastor Strix'Efuartus said:

Swift Raptor has no anim files

 

24 minutes ago, Alastor Strix'Efuartus said:

Anims are in M2s and possibly in anim files if needed



Animations are in M2s but can also be present in .anim files if needed what you dont get about it ? 

Share this post


Link to post
Share on other sites

Like I said... The Swift Riding Raptor animations are not located in the m2, because when I replaced the m2 with a different one the model still animated itself as if it was using Swift Riding Raptor animations. This means the animations are located elsewhere, perhaps in .anim files I cannot find. But you began this thread by stating that the Swift Riding Raptor has no .anim files. I am trying to find those files to change them.

Share this post


Link to post
Share on other sites

I've found an existing edit to do it for me. Might as well consider this topic closed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now