Thoraric

Simple Blender Question- UV

I modified a texture in blender, but when I reopened the model in blender the textures weren't save in the new position. I clicked the button like in the image "Save all Images" but it didn't save. How to apply changes on the wmo-s texture?
On the picture you can see my texture which weren't save after export the wmo. And it changed to standard position.
 

save image.png

Share this post


Link to post
Share on other sites

The WMO exporter does not care about applied textures. It reads materials. I suggest you using Material Utils plugin for Blender to automatically "bake" material units from applied textures. Also do not forget to do Edge Split to avoid T-vertices. 

  • Like 1

Share this post


Link to post
Share on other sites

Oh now I see, and where is the plugin? I don't see it in download section :/

Share this post


Link to post
Share on other sites

Google it. It is a blender thing, not a wow modding thing. Though, I am thinking of releasing some kind of WoWModding blender build with all the stuff convinient installed.

  • Like 1

Share this post


Link to post
Share on other sites

In newer versions of blender it's already in, you just need to launch it in user preferences.

Share this post


Link to post
Share on other sites

I checked it and "Material: Material Utils" is checked in my blender, so it can't be the source of the problem

Share this post


Link to post
Share on other sites

You need to bake materials from texture units. Checking it does not change anything but only turns on the plug-in.

Share this post


Link to post
Share on other sites

I mean I checked that the plugin is checked= there is a check in the little bracket :D

Share this post


Link to post
Share on other sites

The plugin does not do anything by itself. You need to select all your stuff and press Q and then bake materials from Texture Units.

Share this post


Link to post
Share on other sites

I should check the "Bake to Vertex Color" right?

I don't see any change when I press Q" and can't find bake materials from unit option in the UV editor menus.

savematerial.png

Share this post


Link to post
Share on other sites

As Skarn said you just need to go to edit mode, select all faces, press shift+Q and select here materials from pictures

  • Like 2

Share this post


Link to post
Share on other sites

Bah Yesterday I thought it worked but I was sleepy to inspect it in Model Viewer. 
Steps what I do: Import wmo, edit mode, shift+Q, select by material, choose the roof material, in the right window i replace the image then I press shift+Q again, and material to texface.
In modelviewer thw whole model went white. 

I don't have materials from pictures choice.

house.png

Share this post


Link to post
Share on other sites

by the way if you need to just replace the texture of roof then import your wmo, go to material tab, select roof material here and in wow material tab change the path to your texture and then export your wmo

Share this post


Link to post
Share on other sites

my wmo cause crash now :o while in noggit and in modelviewer it looks fine

Share this post


Link to post
Share on other sites

If I choose textface to material the whole model turns white

Share this post


Link to post
Share on other sites

When I choose textface to material the blender delete every single texture from the model, I have to put them on again? And how to adjust the material? And why is it crash when I try to look at the model in game? :(

churchdraenor.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now