elireth123

WOD: _env shader problem on ADT

greetings MCNET

Currently I have a problem with a flag of the WDT and I'm not sure how to fix it.

I have managed to turn a modified map of WOLTK and make it work successfully in WOD (Thanks to Ghaster and PhilipTheNoobModder) but I've found a new problem (which I expected).

The problem: I managed to change 2 ADT Elwynn Forest and modify successfully. The problem is that, if activated in the WDT flag "0x4 _env shader" the ADT brought from WOLTK immediately make crash.

If the flag is not activated, the other "ADT" begin to have strange textures and cube-shaped or even cause crash

Here some pictures:

The modification made:

WoWScrnShot_071416_050402.jpg.3cb6d6a35d

The error:

WoWScrnShot_071416_011750.thumb.jpg.3cbbWoWScrnShot_071416_011757.thumb.jpg.a178WoWScrnShot_071416_011814.thumb.jpg.6f44

I've been reading and found a post that has to do with small and big data being read in the ADT.

Is there any way to activate env shader in the ADT converts?

 

Sorry for my English and thanks.

Share this post


Link to post
Share on other sites

New world uses big alpha. Old world uses small alpha. You need to somehow convert small to big alpha (it is possible in theory) and it will work fine. There are can only be one type of alpha on one map.

  • Like 1

Share this post


Link to post
Share on other sites
55 minutes ago, Skarn said:

New world uses big alpha. Old world uses small alpha. You need to somehow convert small to big alpha (it is possible in theory) and it will work fine. There are can only be one type of alpha on one map.

So for the moment there is no method to make this possible. What a pity. It was modifying some classic maps for roleplay server.

I keep trying, but I guess no one else is investigating this.

What is the theory behind this conversion of which you speak?

Share this post


Link to post
Share on other sites

Sorry for the double post

I was thinking. Perhaps this problem can not be solved now, but if I could move data from the "ADT" woltk maybe I could at least "fix" things up a bit.

So I ask the veterans in this:

Is it possible to transfer data from M2, WMO (positions in the world), holes and height of the map to another ADT (the same adt. Example: WOLTK 31_49 to 31_49 WOD) in WOD?

This obviously should be done in 010 editor. I do not have much experience with it, but if possible (although currently do not know how. greatly appreciate it if someone teaches me) at least would facilitate edit classic maps in small portions (in my case, just 2 adt).

Thank you for reading

Share this post


Link to post
Share on other sites

Add me on Skype, we will try something.

The theory is that smal alpha is 2048 pixels for chunk and big alpha is 4096 pixels for chunk. The conversion is possible as Noggit does the same thing. When you are editing stuff it edits them as 64x64 pixmap while on saving it gets converted to small alpha (32x64) pixmap. Correct me if I am wrong, experienced guys, please.

  • Like 1

Share this post


Link to post
Share on other sites

Done. Added to skype.

We may have to take a look at the code of noggit for answers. But if they succeed, then we should do so.

I'm willing to try, maybe this will motivate others to work more on WOD.

Share this post


Link to post
Share on other sites

If you want to check the code in noggit (for uncompressed (2048) :

 

And yes you're right Skarn.

I'd like to help you but I'm stuck on a problem and I'm busy today, sorry.

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Adspartan said:

If you want to check the code in noggit (for uncompressed (2048) :

 

And yes you're right Skarn.

I'd like to help you but I'm stuck on a problem and I'm busy today, sorry.

 

 

 

Do not worry, when you have time just come by here and see what we can do. This will surely help a lot in the future to others who try to get their hands on WOD.

Thanks for the code, I'll look when I get home.

Share this post


Link to post
Share on other sites

Hello

I have same problem on Legion. Did you get it to work? I suck at coding.. but ready to learn.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now