Sign in to follow this  
Valtorei

help
Downporting Legion Models

Heya, guys.

 

I'm new to the modeling scene for WoW, so I apologize for any "noob" things I may say/do. I am eager to learn, however I have hit a massive road block. As of now, I only have Legion installed, so the only way I can get updated models from my Casc Viewer is by using my Legion client. Well, because of this, when I extract .m2s and other data, I'm required to use m2Mod to convert it to an m2i so I can use Blender, texture, and downport or whatever. I'm pretty sure that's what I need to do. Well, in this situation, I get stuck on the conversion from the Legion .m2 file to the m2Mod file. I have one of two issues. My first being the .m2 file is usally yelling and saying it's corrupt, and the second being if I use the multiconverter, I get another fun error when I convert it after the multiconvert "fixes" it. So I'm not sure what to do here, and any and all help is appreciated.

Also, I'm new to the forum and I apologize if this isn't in the right section!

Share this post


Link to post
Share on other sites

Use this tool for legion and all other, expansion:

https://puu.sh/sR5jq/75cf221e83.rar

https://puu.sh/sR5qt/e34e5f8990.rar

this one hard to find but it supports the m21 models from legion directly.

 

Or if you have the M2Mod 4.6 and 010 Editor for downporting to other expansion, just open the model in 010 and delete the M21 chunk (everything) before M20 then change the 12 you might have on the first line to a 10 and save. you will be able to get the m2i if everything's fine but the tool i linked you does legion convert and export to legion format too.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/30/2017 at 5:30 AM, Roccus said:

Use this tool for legion and all other, expansion:

https://puu.sh/sR5jq/75cf221e83.rar

https://puu.sh/sR5qt/e34e5f8990.rar

this one hard to find but it supports the m21 models from legion directly.

 

Or if you have the M2Mod 4.6 and 010 Editor for downporting to other expansion, just open the model in 010 and delete the M21 chunk (everything) before M20 then change the 12 you might have on the first line to a 10 and save. you will be able to get the m2i if everything's fine but the tool i linked you does legion convert and export to legion format too.

Dude, you are my hero. ❤️

 

Okay, so now I'm getting another "error" of sorts, only this time it's from Blender whenever I try to open an m2i file. My Blender 2.49 outputs and error and my Blender 2.78 won't import m2i files.

 

The error is as follows:
 

Compiled with Python version 2.6.2.
Checking for installed Python... got it!

importing: "C:\Users\Colin Sexton.Colin\Desktop\Model Extraction\CREATURE\RAVEN\raven.m2i"
        v4
Traceback (most recent call last):
  File "C:\Users\Colin Sexton.Colin\Desktop\Blender 2.49\.blender\scripts\import_m2i.py", line 364, in LoadUI
    Load( FileName )
  File "C:\Users\Colin Sexton.Colin\Desktop\Blender 2.49\.blender\scripts\import_m2i.py", line 225, in Load
    InVertexTexture.append( BinaryIO.ReadFloat32( file, endianness ) )
  File "C:\Users\Colin Sexton.Colin\Desktop\Blender 2.49\.blender\scripts\BinaryIO.py", line 26, in ReadFloat32
    return struct.unpack( Endianness + "f", File.read( 4 ) )[0]
struct.error: unpack requires a string argument of length 4

 

Share this post


Link to post
Share on other sites
9 hours ago, Roccus said:

Did you install the scripts i gave you in blender ?

 

I did, yes.

Share this post


Link to post
Share on other sites

You speak about 2.78 but your error talks about blender 2.49 so your blender doesn't call the right script in my opinion.

Share this post


Link to post
Share on other sites
4 hours ago, Roccus said:

You speak about 2.78 but your error talks about blender 2.49 so your blender doesn't call the right script in my opinion.

I said that I tried with both versions of Blender and they both produce the same error, so I thought it redundant to post the same error message that two versions of Blender produce...

 

So the issue may lie in the scripts, or perhaps they lie in Blender. That's what I'm trying to figure out.

Share this post


Link to post
Share on other sites

Did you check the settings on the M2Mod 4.8 to see if you put merge attachment camera bones et forced Legion format ? Last thing i can see there, It worked for the guys i shared it with, i don't know maybe you are doing something wrong

Share this post


Link to post
Share on other sites

Here's a screen shot of the settings.

Untitled.png

 

Steps I'm taking...


Use Casview to extract an .m2 file, the skin files, animation files, and blps.
Use M2mod to convert the .m2 to an .m2i
Try to open the .m2i in Blender

Encounter and error.

Share this post


Link to post
Share on other sites
4 hours ago, Roccus said:

can't help more, should be workin', sorry

I mean, you tried. I just don't get why it won't work. I've done literally everything every tutorial has asked for, and Blender just fails to work. Maybe I'm missing something and I just don't realize it... I wish there were more people inputting what they thought too. :/

Share this post


Link to post
Share on other sites

so when you try to convert m2 to m2i it say your m2 file is corrupt ?

if that so I think there is 2 problem

1- you removed the header and tried to convert using m2mod 4.8 show me a picture of you m2 in 010

2- the m2 have animated texur new legion ribbon or fucked up legion particle try to change them to 0

Share this post


Link to post
Share on other sites
On 5/2/2017 at 11:54 AM, MR.Farrarie said:

so when you try to convert m2 to m2i it say your m2 file is corrupt ?

if that so I think there is 2 problem

1- you removed the header and tried to convert using m2mod 4.8 show me a picture of you m2 in 010

2- the m2 have animated texur new legion ribbon or fucked up legion particle try to change them to 0

GWhviuB.png

 

Maybe I'm missing something here. I never fully understood the 01 Editor... :/

Share this post


Link to post
Share on other sites

Heyho, i try your model and it work with no problem.

I used same tools and blender 2.76

Maybe you should check again in blender wich script it use or reload the stormcrow model maybe it is fucked up by one of your trys.

Share this post


Link to post
Share on other sites
18 hours ago, Finsternis said:

Heyho, i try your model and it work with no problem.

I used same tools and blender 2.76

Maybe you should check again in blender wich script it use or reload the stormcrow model maybe it is fucked up by one of your trys.

Think it could be from the extraction? I am extracting from my updated 7.2 WoW client with CascViewer.

 

Also, where can I find scripts? I can't be sure mine are the right ones at this point. I'm currently reinstalling/downloading all the programs.

Share this post


Link to post
Share on other sites

you can't, those are the ones, 7.2 or 7.1 work

Share this post


Link to post
Share on other sites

EDIT: FIXED! See solution below. Might help someone.

=============================================================================

Tried to convert nightelffemale_HD.m2 to .m2i and Blender always returns this:

GEtGDyZ.png

I followed this video, version 2.7.3 of Blender with M2Mod 4.8 and scripts Roccus provided but nothing works.

 

Also, merge bones etc. settings in M2Mod Redux are all checked and set to Legion. I extracted from 7.2 retail client and tried with 7.1.5 client as well (even tried 4.3.4 and 5.1.0 clients for older m2 files). Nothing imports.

================================================================================

EDIT:

The problem is wow_props in .py scripts. Removed it and my model loaded perfectly.

Share this post


Link to post
Share on other sites

Still not normal, i didn't edit anything in those script and i could import everything even 7.2

Share this post


Link to post
Share on other sites
2 hours ago, Roccus said:

Still not normal, i didn't edit anything in those script and i could import everything even 7.2

 

I have no idea how you are so lucky. I have had to use downported versions of WoW, M2Mod Redux 4.6 and different scripts to import/export properly.

Share this post


Link to post
Share on other sites

I almost wonder if I'm missing something the the 010 Editor... I just don't know what it could be.

Share this post


Link to post
Share on other sites

 

On 2017-5-6 at 8:05 PM, Bravelad said:

EDIT: FIXED! See solution below. Might help someone.

=============================================================================

Tried to convert nightelffemale_HD.m2 to .m2i and Blender always returns this:

GEtGDyZ.png

I followed this video, version 2.7.3 of Blender with M2Mod 4.8 and scripts Roccus provided but nothing works.

 

Also, merge bones etc. settings in M2Mod Redux are all checked and set to Legion. I extracted from 7.2 retail client and tried with 7.1.5 client as well (even tried 4.3.4 and 5.1.0 clients for older m2 files). Nothing imports.

================================================================================

EDIT:

The problem is wow_props in .py scripts. Removed it and my model loaded perfectly.

Went into the wow import py file. I see there are wow_props all around, but I don't know which things to delete.

Share this post


Link to post
Share on other sites

for 010 if you want to downport to WoD, you have to delete the M21 chunk in 010 of the M2, delete all before the M20 string. then change de 12 of the first hexadécimal line to a 10. Then you can use the wotlk converter script that you can find here to make the model compatible with wotlk. Use it on the skin to (conversion script).

Share this post


Link to post
Share on other sites

Edit: Nevermind. I restarted, it works now. Computer soft locked, it didn't let me move any files. Probably had something to do with that.

Edited by Bhalandros

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this