Serifaz

help
Invisible m2 in game.

Hello all, I have a problem with my m2 I am working on. I can't see it in game, all I see is a shadow.
I am using mdx to m2 lazy I have done this before no problem but for some reason it is giving me trouble now.

I think it is possibly a texture issue but I'm unsure. any ideas?

Share this post


Link to post
Share on other sites
2 hours ago, Serifaz said:

Hello all, I have a problem with my m2 I am working on. I can't see it in game, all I see is a shadow.
I am using mdx to m2 lazy I have done this before no problem but for some reason it is giving me trouble now.

I think it is possibly a texture issue but I'm unsure. any ideas?

Are you backported something? Invisible m2 mean game can't get path to your .m2 file or file itself have some kind of issues.

 Even w/o textures you can see your model with full green/white "textures".

Share this post


Link to post
Share on other sites

No its a new model from scratch built in blender then put in 3ds max and exported to mdx which I am now converting to m2 with mdxtom2 lazy.

and I am replacing the human male model to test it.So I'm unsure why its just not showing anything when I create a human

 

I'm thinking it may be a scaling issue but not sure.

Share this post


Link to post
Share on other sites
17 hours ago, Serifaz said:

Hello all, I have a problem with my m2 I am working on. I can't see it in game, all I see is a shadow.
I am using mdx to m2 lazy I have done this before no problem but for some reason it is giving me trouble now.

I think it is possibly a texture issue but I'm unsure. any ideas?

You are not giving much information, so it's really difficult to help, but an invisible model means (among many other issues):
*Model is broken/has bad offsets. Did you open it with 010editor? Did the template work correctly or it stopped?
*Transparency is 0:0 instead of 0:32767
*
Your model doesn't have bones, or the vertices are not bound to any bone
*.skin file has wrong flags, order, d4 or transid

Share this post


Link to post
Share on other sites

sorry for not giving much info I just didn't know what info to give I will check those things and update post with what I find out. 

 

[edit]So I checked 010 and there was a quite a few warnings.

Spoiler

 

*WARNING Line 1274: Variable '_globaseq' not generated since array size is zero.
*WARNING Line 543: Empty structure.
*WARNING Line 555: Empty structure.
*WARNING Line 760: Empty structure.
*WARNING Line 772: Empty structure.
*WARNING Line 543: Empty structure.
*WARNING Line 555: Empty structure.
*WARNING Line 543: Empty structure.
*WARNING Line 555: Empty structure.
*WARNING Line 760: Empty structure.
*WARNING Line 772: Empty structure.
*WARNING Line 543: Empty structure.
*WARNING Line 555: Empty structure.
*WARNING Line 1310: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 807: Empty structure.
*WARNING Line 819: Empty structure.
*WARNING Line 1371: Variable '_AttachLookup' not generated since array size is zero.
*WARNING Line 1373: Variable '_Events' not generated since array size is zero.
*WARNING Line 1376: Variable '_BoundingTriangles' not generated since array size is zero.
*WARNING Line 1378: Variable '_BoundingVertices' not generated since array size is zero.
*WARNING Line 1380: Variable '_BoundingNormals' not generated since array size is zero.
*WARNING Line 1404: Variable '_CamLookupTable' not generated since array size is zero.
*WARNING Line 1428: Empty structure.


 

Also I forget where I saw it but zim4k a while back did a tutorial on how to fix offsets and cameras I can't find it tho.

nTransparency in the 010 editor is 38 I am unsure if that is the transparency I need to change though.

 

also I don't know weather this is worth noting but when I convert the model from mdx to m2 it only gives one skin file instead of three.

I checked the skin file aswell and the template ran with no warnings or errors

I don't really know how to match up the flags properly so if you could let me know how to fix the skin issues or look for them that would be awesome ;).

 

I do have the model bound to bones so I know that isn't the issue there are only two bones the base bone and the second is a child of the base bone which again controls the whole model.

Share this post


Link to post
Share on other sites
1 hour ago, Serifaz said:

there was a quite a few warnings

That happens with all models. Nothing wrong there. When your model is broken it says "ERROR" instead of "WARNING".

1 hour ago, Serifaz said:

nTransparency in the 010 editor is 38 I am unsure if that is the transparency I need to change though.

 

That's the amount of transparencies. You should check the value of each one of them. It should be "32767". I don't know why your model has so many. Usually it's 1 transparency for each geoset, so if your model has 38 geosets that may explain everything.

AlZ3WaZ.jpg

1 hour ago, Serifaz said:

also I don't know weather this is worth noting but when I convert the model from mdx to m2 it only gives one skin file instead of three.

 

The amount of skin files depends on the polygon count of your model. More polygons means more .skin files. However you can just modify your .m2 to only read one skin file (mdxtom2 does that by default, so all your models will have only 1 .skin file).

1 hour ago, Serifaz said:

I don't really know how to match up the flags properly

Open the chicken or the rabbit model and copy the same flag/d4 values. Those are the most basic models in the game. Usually d4 should always be 1 and flags 0.

1 hour ago, Serifaz said:

Also I forget where I saw it but zim4k a while back did a tutorial on how to fix offsets and cameras I can't find it tho.

 

But your model doesn't have cameras and offsets seem to be ok.

Post your model if you want and I will give it a look.

Share this post


Link to post
Share on other sites

I just realized the transparency values in each field are 0

crap double post

I think I might be able to fix this. I think its a material issue Im having actually.

Share this post


Link to post
Share on other sites
22 minutes ago, Serifaz said:

I just realized the transparency values in each field are 0

crap double post

I think I might be able to fix this. I think its a material issue Im having actually.

Just checked your model. The problem was indeed caused by transparency. It has 0:0 instead of 0:32767.

I opened the model with pymodeleditor and modified all transparencies (go to Transparency-> Edit-> and paste "0:32767". Click on "ok" and change to the next transparency id. Do the same with all the other 37 ids).

Now the model is visible in-game.

Share this post


Link to post
Share on other sites

You need to go through your M2 with the template and search for renderflags ID, one that has opaque and twosided flags. Then go in skn00 and search for the geoset you want to be two-sided. Then in skin01 search the same geoset and replace in texture..... structure the renderflag ID by the one of the M2 that has the two_sided setting.

 

Or simpler. Go on you model on blender. Select your geoset. go to edit mode, select all in the left menu, chose duplicate. Right click to deselect the moving duplicata and go to shading menu if i remember correctly and "flip directions" to flip normals side. So you won't be needing to edit skin files to have the two_sided effect. But your model will have more vertices which can be a problem for 335 version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now