Basto&co

  Contributors
  • Content Count

    106
  • Joined

  • Last visited

Community Reputation

87 Excellent

About Basto&co

  • Rank
    MC.net Guy
  • Birthday June 4

Personal Information

  • Specialty
    Level Design
    DBC Editing
    Modeling
    Machinima
    Lore/Quests

Contacts

  • Skype
    Discord:bullfrog#3719

Recent Profile Visitors

9,886 profile views
  1. Stuck in my head. One of my champ's have a problem with upshowing weapons of npc's. Somebody have a straight tut for me?

    1. Show previous comments  1 more
    2. Basto&co

      Basto&co

      Thanks a lot, @Zehlendorf . Well know this video, but might dont help. Let me explain the prob: Also when he spawn a NPC, for example a standard stormwind guard who have by default a weapon - its not upshowing. Its like... there is a command missing or smth. like that. 

       

    3. Zehlendorf

      Zehlendorf

      Hmm i had that problem, but was because i use a custom Item.dbc, and I do all the steps in the video, first generate in my db all the missed items that are in the originally Item.dbc, then generate a new Item.dbc with all that missed items and the custom ones, then all the npcs in this case the guardians of stormwind or orgrimmar appears with their own weps without any problem.

    4. Zehlendorf

      Zehlendorf

      That's all I did and it worked, I remember it was a headache because I had created custom bosses but the weapon did not show, after doing the steps of the video everything was perfect, I doubt there is any command or something similar. Good Luck

  2. Yeah sure. Thats why i checked all .dlls about their "bit-version". And yeah they are all now the same 'nd it dont work atm. =/
  3. Greetings Community! I hope you can help me plus i hope its the right topic-section. I've try the last 4 days to solve the problem behind "0xc000007b". I try to mod on WoD, so i download the modding-kit & server kit from modcraft.io for WoD. First there where some .dll's missing - i checked this and got them. So every time when i start my world-server.exe i get the "0xc000007b"-problem. What i've done till now: 1. I kicked all .dll's, redistributable (x86, x64), programms who can install wrong .dlls (for example, .net framework, adobe, visual studios and so on) and reinstall them all rightly for my bit-version. Now i dont have any problems yet about this freaky-fucking missing .dll but always get the 0xc000007b-fail. 2.) I also checked with "Depends22" the bit-version of the needin' .dlls. 3.) I've try to install a clean AIO-runtimes, to get the standard-windows-programms clean (Java, Adobe and so on) Notes: It works all fine for my 335a worldserver.exe/noggit/WMW ect. and modding workplace, no problems, no 0xc000007b's (at the beginn of my reinstall i checked this, i killed some .dll's who are needed but i get them back so it work fine again) I dont have any knowledge about registry-working, so i never touched them to do it by myself - repairing or look if they are damadged (I hope not!) Greets, Basto&co
  4. Thanks! I will check this out. First of all i need a general custom-patch with all stuff back. Will return and give you some stars
  5. Hell! My modding hard disc fucked up D:

     

    1. Show previous comments  4 more
    2. Bardh

      Bardh

      Same happened to me today. Need to re download Wotlk and compile the sever all over again.Some of my files are saved but still, plenty loss of time.

    3. Basto&co

      Basto&co

      Aww i feeling yah bro. Why dont try to start with wod? Btw. on wich Plattform did you compile? I have just a guide for Linux but i wanna do also one for Windows for me and beginners. Maybe you can help me some Day? 

       

    4. Bardh

      Bardh

      I have always used Windows, never had problems and I compiled the server yesterday for about one hour(I had my WOTLK client on laptop and quickly moved the files while I also saved vmaps and mmaps  which take quite long to extract). My disk failed while I was downloading WOD 6.2.4 client, I'm really interested in WOD modding but I won't "experiment" right now with my disk.If you need any help you can just pm me.

  6. Thanks dude! Now i know how this kind work also on gimp! (grids - slices - sub-areas, THANKS!) "Save for web": Wich data-ending did you mean? .xhtml?
  7. /* Install a WoW Server on Linux (Debian 8.0) from scratch Wrote by Basto, after the 6th reinstall! (Server raid) You are allowed to share this with credits */ _____________________________________________________ -First of all: <apt-get update> <apt-get upgrade> <apt-get install> # You can do this always. So you keep your Server up to date _____________________________________________________ -Secuity#1: #Change default User-Root-Password <passwd "Username"> # Enter password two times #Add new User for more security <adduser "Username"> # Enter password two times _____________________________________________________ -Security#2: #SSH default Port change. Set the port new. Example 9988 <nano /etc/ssh/sshd_config> #SSH Root Login denied. Note: Now you have to login with your new Username. When you have something to install, switch on the SSH window the username to root with [su <User>]. The intention about this is, nobody can hack you with the always known username "root" <nano /etc/ssh/sshd_config> #Change the row from (Yes - to no). You can use STRG + W (left klick to paste your searching copy to find it). CTRL + O = Save CTRL + X = Exit "PermitRootLogin yes" to "PermitRootLogin no" </etc/init.d/ssh restart> _____________________________________________________ -General Settings & install: <apt-get install screen> # See also "Screening for Idiots" <apt-get install mysql-server> # See also "MySQL Configs to reaching from outside" _____________________________________________________ -Ground Server Install: <apt-get install build-essential autoconf libtool gcc g++ make cmake git-core wget p7zip-full libncurses5-dev zlib1g-dev libbz2-dev> # Accept <apt-get install openssl libssl-dev mysql-server mysql-client libmysqlclient-dev libmysql++-dev libreadline6-dev> <apt-get install libboost-dev libboost-thread-dev libboost-system-dev libboost-filesystem-dev libboost-program-options-dev libboost-iostreams-dev> # Accept _____________________________________________________ -Core Set-up: <adduser "username"> # We also use here a new Username for more security. For example; wow <su "username"> <git clone -b 3.3.5 git://github.com/TrinityCore/TrinityCore.git> # This task will load the need things <cd TrinityCore> # Move to the Folder TrinityCore <mkdir build> # Build the folder build <cd build> # we move into build... _____________________________________________________ # !Hold on and read first! # To configure the core, we use space-separated parameters attached to the configuration-tool (cmake) - do read the entire section before even starting on the configuration-part. # See also <Parameters> further down _____________________________________________________ <cmake ../ [additional parameters]> # Examples: <cmake ../ -DCMAKE_INSTALL_PREFIX=/home/<username>/server -DWITH_WARNINGS=1> # or <cmake ../ -DCMAKE_INSTALL_PREFIX=/home/wow/server -DCONF_DIR=/home/wow/server/etc -DTOOLS=1 -DWITH_WARNINGS=1> <make -j "number of cores"> # This will take now a little bit of your time. Caused by your core volume <make install> # Finished. Next: Database _____________________________________________________ <<<Parameters:>>> -DSCRIPTS * Build core with scripts included (enabled by default) * -DSERVERS * Build worldserver and authserver (enabled by default)* -DCMAKE_INSTALL_PREFIX Set installation directory -DTOOLS Build map/vmap extraction/assembler tools -DTOOLS=1 (will include tools (and connection_patcher on 6.x)) -DWITH_WARNINGS Show all warnings during compile (advanced users only) -DCMAKE_C_FLAGS Set C_FLAGS for compile (advanced users only) -DCMAKE_CXX_FLAGS Set CXX_FLAGS for compile (advanced users only) -DUSE_COREPCH * Use precompiled headers when compiling servers * (advanced users only) -DUSE_SCRIPTPCH * Use precompiled headers when compiling scripts * (advanced users only) -DWITH_COREDEBUG Include additional debug-code in core (advanced users only) -DCONF_DIR Set configuration directory (advanced users only) -DLIBSDIR Set library directory (advanced users only) _____________________________________________________ -Screening for idiots: <screen -ls> # Look wich screen is atm running <screen -S world> <cd /home/<Username>/server/bin> <./worldserver> or <sh worldrestart.sh> <ctrl + A + D> # for close <screen -S auth> <cd /home/<Username>/server/bin> <./authserver> _____________________________________________________ -MySQL Configs: <apt-get install mysql-server> # Accept and give the local user "root" a passowrd <nano /etc/mysql/my.cnf> # Edit: Topic MySQL -> [Port = 3306] to a own port (Attention, there are two ports, look at the right head-topic. Its also for security) and [bind-address = 0.0.0.0] </etc/init.d/mysql restart> #Now let create us a Username <mysql -p> <"Password who you set at beginning"> <CREATE USER 'newuser'@'localhost' IDENTIFIED BY 'password';> # Example: 'basto'@'%' IDENTIFIED BY '123' % = means from outside <GRANT ALL PRIVILEGES ON * . * TO 'newuser'@'localhost';> # ...On *. * TO means wich database and so on <Exit> _____________________________________________________ -Patching the DB: <mysql -p> <"Password"> <use "Datenbasename";> <source "PathToData";> _____________________________________________________ -Keep the Core Up-To-Date: <cd ~/TrinityCore/> #For 3.3.5 Branch <git pull origin 3.3.5> _____________________________________________________ #Note: #Feel free for feedback or if you have some other ideas #Feel also free, to help to complete it. For the basics. For more transparence. To get more people in the community #Edit1: # Forgott a important " ; "
  8. just have 2 wide one =) Nice @$phynx! I have a very clean one
  9. Did you have maybe the stoneroads of the garrison too or just till cata? or did you know, are they not a part of a map and they are also instance? Because i need some nice "town roads" for my alliance town. Goldshire/elwynn helps me jusg for the forest part of my map :-P
  10. Thanks dude! Srsly. I start 2 days ago to complete my "Road-Template-Set"... now its feel like... "Basto? Trolololololo!" :-D
  11. Index: - Was wir brauchen - Schritt 1 bis 3 - "Auf-den-ersten-blick-alles-verständlich"-Bild Was wir brauchen: - ein WoW 3.3.5a Trinity Server - deine World of Warcraft _world-Datenbank __________________________________ Für Custom Portpunkte: - Noggit für eine Custom Karte - Dein eingebauten Patch Schritt 1: Geh dazu Ingame an einen Platz den du dir wünscht und der dir gefällt - wo die Spieler starten sollen. Nun gib den Adminbefehl ".gps" ein damit wir diese Koordinaten bekommen. Notiz: Sogar die Blickrichtung kannst du für dich entscheiden. Wäre in dem Fall "orientation". Schritt 2: Geh zu deiner Welt-Datenbank (in Navicat oder vergleichbares) worlddatabase -> table: playercreatinfo. Hier siehst du nun die einzelnen location Punkte der einzelnen Rassen und Klassen. Ab der Spalte "Map" beginnen wir die neuen Koordinaten einzusetzen. Probier es für den Anfang nur mal mit dem ersten (Race 1: Mensch, Class 1: Krieger) Schritt 3: Speicher deine Arbeit und restarte die Welt. (Via Konsole oder ingame: ".server restart 1") Dannach probier es mal aus. "Auf-den-ersten-blick-alles-verständlich"-Bild:
  12. Index: - What you need - Step 1 till 3 - One-Look-Understandable-Picture What you need: - a WoW 3.3.5a Trinity Server - your World of Warcraft _world-Database __________________________________ For Custom port-points: - Noggit for a Custom map - Your builded patch Step 1: Go ingame to a nice area, there you want your players to start up. When you found your place - press ingame the Admintask ".gps" to get the coordinates. Note: You get also the sightvew (orientation) Step 2: Go to your world-database -> table: playercreatinfo. So you can see now the single locations of each race. Insert you coordinates to the single collums. Step 3: Save your work and restart the world. (.server restart 1) and try it =) One-Look-Understandable-Picture:
  13. I never touch blizz-maps but i will do a video of that, what @Amaroth said. I indeed with him. But there are little tricks to make this very very fast. Hold on bro
  14. How @Amaroth said: Noggit always need minimum of 3 (or maybe 4 (full)) textures. When you cant fix them with noggit again -> Start the map with a older noggit version. (thats the reason why i have a 1.2 version on my computer, idk WHY the older open it) You dont have to make it show, the textures have only to be in the (1by4 texture tabelle) so take any texture (little hint, i take crap single-clors (red/blue/green) set the pressure and hardness down and draw over all .adts) so that problem will be solved. Its very important in general by modding with noggit (actually blizzlikezones or new one) Next problem maybe: It is possible, that yah have a .wmo/.m2 not standing out of WOTLK? For example, Cata/MoP or some higher? Than you need a "hexed" wow.exe (i dont know what this say exactly, i only know, that the general things need a better version of the exe, so we have to edit them) So thats my ideas about that... poooh. I thought my Noggit Version is broken or something Greets